워드프레스 테마 설치 시, 400 Bad Requeset 오류 해결 방법

Your browser sent a request that this server could not understand.

오늘 cafe24에 새 계정에 워드프레스 설치를 도와줄 일이 있어서 하는데, 테마 업로드 시에 위와 같은 에러가 나왔다. 평소에 본 적이 없는 에러라서 이게 왜 발생하나 알아봤더니, PHP 5.5 에서는 저런 에러가 발생한다고.

PHP 5.3 이하 버전에서는 상관없는데, 5.5에서는 7메가(?) 이상의 용량을 올릴 때 위와 같은 에러가 난다고 한다. (7메가가 기준인지는 확실치 않음. 내가 올린 테마는 9메가)

php.ini 파일을 설정해주면 해결이 된다고 하나, 웹호스팅 업체의 신세를 지고 있는 입장이라면 그게 쉽지 않을테니, 5.3이하로 다운그레이드를 하면 매우 쉽게 해결된다.